Disappearing tags

Discuss Tag, an open source metadata editor for audio files.
Post Reply
The Gonif
Posts: 7
Joined: Thu Apr 17, 2008 12:23 pm

Disappearing tags

Post by The Gonif »

Hi there,

Something odd just happened with Tag -- can someone tell me if this is normal? I've been tagging some Monkey's Audio (.APE) music files on my PowerPC Mac. When I read those files into Tag on an Intel Mac, the tag metadata all comes up blank. If I tag the file on the Intel Mac and then open it in Tag on the PPC Mac again, then *it* comes up with blank metadata.

Is there some endian issue at play here? Is this a known issue?

Thanks!

User avatar
sbooth
Site Admin
Posts: 2456
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Re: Disappearing tags

Post by sbooth »

Does this problem happen with other files types (FLAC or Vorbis) or only with APE files?

The Gonif
Posts: 7
Joined: Thu Apr 17, 2008 12:23 pm

Re: Disappearing tags

Post by The Gonif »

Ah, that's it. It seems that it is only .ape files that come up with blank metadata when viewed in Tag on the Intel Mac; flac files are fine. Do you think there's a bug in the Mac port of the Monkey's Audio code? How surprising that nobody noticed this before!

User avatar
sbooth
Site Admin
Posts: 2456
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Re: Disappearing tags

Post by sbooth »

It could be a bug in the port, or it could be an error in the compilation. I'll see if I can figure it out.

The Gonif
Posts: 7
Joined: Thu Apr 17, 2008 12:23 pm

Re: Disappearing tags

Post by The Gonif »

Stephen, have you had a chance to look at this? I was 1/2 way through the huge project of tagging my music collection when I noticed the issue. I'm not sure if I should continue using the PPC Mac or start over using the Intel Mac.

Thanks!

User avatar
sbooth
Site Admin
Posts: 2456
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Re: Disappearing tags

Post by sbooth »

I haven't had a chance yet to investigate this.

The Gonif
Posts: 7
Joined: Thu Apr 17, 2008 12:23 pm

Re: Disappearing tags

Post by The Gonif »

Ok, no worries. I just thought I'd follow up. Whenever or ifever you get a chance, that'd be great.

Thanks!

The Gonif
Posts: 7
Joined: Thu Apr 17, 2008 12:23 pm

Re: Disappearing tags

Post by The Gonif »

Just out of curiosity, has anyone else noticed this?

Dim
Posts: 1
Joined: Wed Nov 12, 2008 2:35 am

Re: Disappearing tags

Post by Dim »

Yes, the same here. The tag fields of APE files filled on a PowerPC look blank on MacBook Pro. They look blank not only in Tag, but also in Cog and Play. Moreover, they also look blank when run under Windows XP (Foobar2000) on a MacBook Pro.

Post Reply