Page 1 of 1

Sparkle failure updating to 0.7

Posted: Mon Jan 08, 2007 9:04 am
by Maurits
First of all, congratulations on getting 0.7 out. I'm sure I'm not the only one that's very grateful for all the work you put into this! :D

Now, there seems to be something wrong with the Sparkle update mechanism for this release. It says there is an update, starts to download it but in the end it fails saying: "An error occurred while extracting the archive. Please try again later."

When I look in the actual appcast.xml I notice the date and length are wrong, could that be it? You don't seem to use the MD5 sum option to ensure download integrity so that option won't be causing the message, the download could be corrupt though.

Posted: Mon Jan 08, 2007 1:59 pm
by sbooth
It's probably because I tried to save space by using a .tar.bz2 archive instead of a zip file. I will point the appcast at the .zip file.

Posted: Mon Jan 08, 2007 3:12 pm
by mdewakanton
Works fine for me. Thanks :D

Posted: Mon Jan 08, 2007 3:37 pm
by Maurits
You're right, it's all working now...