RIP CD to iTunes - Apple Lossless: iTunes 8.0.2, OS 10.5.5

Discuss Max, an open source CD audio extractor and audio converter.
Post Reply
Why-r-less Voyager
Posts: 1
Joined: Mon Dec 08, 2008 12:14 pm

RIP CD to iTunes - Apple Lossless: iTunes 8.0.2, OS 10.5.5

Post by Why-r-less Voyager » Mon Dec 08, 2008 12:46 pm

Hi there. I have successfully ripped a CD into a folder, having set encoders settings to Apple CAF (Apple Lossless) in the 'format' menu. On the 'Output' screen, I have tried both 'default' and 'same as source file' - no issues, I CAN see the output files. Options are set at 'Overwrite existing output files' and 'save encoder settings in comment, plus 'Delete source files after encoding.' I've played with these to no beneficial effect.

Trouble is, the output files are not imported to iTunes. When I try and play the individual files, they play fine in Quicktime, which opens by default. Trying to change to default has no effect. Nor can I drag and drop the individual or collective files into my iTunes music folder from the destination folder - I get no 'green plus' to indicate the drop is optional, and they do not copy over.

The other options that are set are: iTunes options: the following are checked: 'Use iTunes compatibility mode'; 'Add output files to iTunes library'; 'Add files to playlist.' I've played around with these trying to specify a playlist location, and is currently set to {sourceFilename}

The iTunes library as shown in iTunes 'Preferences' is in the default Mac location, and no extra folders are files are stored here after 'importing' from Max. The Advanced tab of iuines is set to 'keep iTunes Music Folder organized' and 'Copy files to Itunes Music Folder when adding to library.'

Help! I like the sound quality produced by ripping with MAX, but surely things can't be that complicated to rip and transfer into iTunes? Where am I going wrong here??? :roll:

RonaldPR
Posts: 433
Joined: Tue May 30, 2006 8:27 am
Location: Amsterdam, Netherlands

Re: RIP CD to iTunes - Apple Lossless: iTunes 8.0.2, OS 10.5.5

Post by RonaldPR » Mon Dec 08, 2008 1:29 pm

You used the wrong format. Choose the first "MPEG4 Audio" and then choose "Apple Lossless". The files will have .m4a extension.

(Please remove the other two identical postings.)

Post Reply