No iTunes content showing in Browser

Discuss Decibel, a high quality audio player.
Post Reply
Haydar
Posts: 3
Joined: Mon May 28, 2012 6:17 am

No iTunes content showing in Browser

Post by Haydar » Mon May 28, 2012 6:26 am

Hello,

Using Decibel 1.2.8 (28), OS 10.6.8, iTunes 10.6.1 (7), iMac i7 2.03 GHz

I have the iTunes Browser plug-in checked and configured to go to the "iTunes" folder, with a green check mark next to the drop-down menu. What am I missing?

Thanks,
david

User avatar
sbooth
Site Admin
Posts: 2447
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Re: No iTunes content showing in Browser

Post by sbooth » Mon May 28, 2012 1:58 pm

Does your iTunes library contain protected AAC files? If so, they won't show up in Decibel.

One thing you can for troubleshooting is to navigate to your iTunes music folder in Finder and find the file called "iTunes Music Library.xml" or "iTunes Media Library.xml". Move the files aside (or delete them), then run and immediately quit iTunes. The files should be regenerated when iTunes quit. After this, on launch Decibel will reread the new .xml file and hopefully pick up the new tracks.

Haydar
Posts: 3
Joined: Mon May 28, 2012 6:17 am

Re: No iTunes content showing in Browser

Post by Haydar » Mon May 28, 2012 10:51 pm

Thanks for responding so quickly.

It's not that the AAC protected files were the only ones not showing up; NOTHING was showing up. But I tried your suggestion. When I removed my Library and regenerated the .xml file, there was nothing showing in the iTunes app at all! So, I re-installed the old library, and all is well, at least in iTunes; all files are accounted for. But the problem of there being nothing to browse in Decibel is still an issue; it's completely blank.

Am I missing something??!

Thanks, again,
david

User avatar
sbooth
Site Admin
Posts: 2447
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Re: No iTunes content showing in Browser

Post by sbooth » Tue May 29, 2012 10:53 am

Deleting those files should not affect iTunes at all, so what happened is very strange. iTunes writes those files specifically for outside apps to use and AFAIK doesn't use them for anything. I assume that you only moved the .xml file(s)?

pl_svn
Posts: 98
Joined: Thu Jan 26, 2012 12:34 pm

Re: No iTunes content showing in Browser

Post by pl_svn » Tue May 29, 2012 10:46 pm

Haydar wrote:Am I missing something??!

now that all is fine in iTunes, quit it, go to "user/Music/iTunes" and delete "iTunes Music Library.xml" (and, if present, also "iTunes Library.xml")

launch iTunes, start playing a song, skip to the last few seconds and let iTunes begin playing next track: *now* "iTunes Music Library.xml" has been recreated and should be available to other apps ;-)

Haydar
Posts: 3
Joined: Mon May 28, 2012 6:17 am

Re: No iTunes content showing in Browser

Post by Haydar » Thu May 31, 2012 5:12 am

OK, I trashed just the xml file, relaunched iTunes, and a new xml file was created. Still the same problem. Attached is a screen shot.

I double-checked the plugs in preferences. Screen shot attached. This may not matter, but inside the iTunes folder is a folder "iTunes Music" and inside that are all the folders with mp3s, etc. However, if I choose the iTunes Music folder, I get an alert. Screen shot attached.

So, I'm pretty stumped at this point!

Thanks,
david
Attachments
iTunes Music is not %22ok%22.png
iTunes browser plug-in %22ok%22.png
No iTunes content!.png

pl_svn
Posts: 98
Joined: Thu Jan 26, 2012 12:34 pm

Re: No iTunes content showing in Browser

Post by pl_svn » Thu May 31, 2012 11:01 am

... if you have selected your "iTunes" folder(*), *not* "iTunes Music" folder, and it doesn't work then... there's actually something wrong and I hope Stephen can better help you here :-/

(*) and if it actually is the correct one (are you sure you're not pointing Decibel to some other empty iTunes folder you may have?)

figgis
Posts: 2
Joined: Wed Apr 02, 2014 3:35 pm

Re: No iTunes content showing in Browser

Post by figgis » Thu Apr 03, 2014 10:29 am

I have used Decibel for over a year with no problems, but as of 02/04/14 I now get no tracks in iTunes browser. I have deleted and generated a new file as in previous instructions but has made no difference.
I haven't altered any settings or software so I am at a loss as to why this has happened. Has anyone come up for a solution to this problem? As it seems that I am not the only one affected.

Figgis

figgis
Posts: 2
Joined: Wed Apr 02, 2014 3:35 pm

Re: No iTunes content showing in Browser

Post by figgis » Tue May 20, 2014 3:53 pm

I have swapped emails with Feisty Dog Customer Support and guess what, they don't have a clue what the problem is perhaps a name change is in order to Feisty Dog NO Customer Support. :x

Post Reply