Hog mode and clicking problem

Discuss Decibel, a high quality audio player.
Post Reply
mystertee
Posts: 1
Joined: Sun Jun 12, 2011 3:32 pm

Hog mode and clicking problem

Post by mystertee » Sun Jun 12, 2011 3:36 pm

I've seen "hog mode" mentioned here in the forum, how do you turn it on (or off)?

I'm experiencing a clicking sound during playback, how do I eliminate that?


Thanks.

User avatar
sbooth
Site Admin
Posts: 2450
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Re: Hog mode and clicking problem

Post by sbooth » Sun Jun 12, 2011 4:38 pm

Hog mode is turned on and off via the "Obtain exclusive access" checkbox in the preferences.

Other people have experienced the popping/clicking you're experiencing as well. The issue does not seem to be limited to Decibel; I know of at least two other programs suffering from the same issue. It seems to be limited to certain hardware (Apple hardware, not DAC) configurations. I'm actively working on the issue but I do not have a resolution at this point. I did file a bug report with Apple and I believe the problem will be address in a future update to Mac OS X.

Is your USB DAC plugged directly into your MacBook Pro? I am able to reproduce this problem with one of my DACs, and for some reason when I plug my DAC into an external USB hub the problem disappears. The other solution is to disable hog mode.

It's also worth noting that the problem seems to occur on certain older models of MacBook Pros only- a user who had the problem upgraded to a newer machine and it went away.

bommai
Posts: 2
Joined: Tue May 03, 2011 7:24 pm

Re: Hog mode and clicking problem

Post by bommai » Sun Jun 19, 2011 4:26 am

I am using a Musical Fidelity V-Link USB to Toslink converter and I ran the demo version of Decibel. I also go a lot of clicking or even pops with Decibel. I did not even check if hog mode was enabled but I think it was. However, when I moved the USB cable to a powered hub (I am using one made by Plugable), it went away. I am using it on an iMac 24" 2.8GHz from 2007 with 6GB RAM. I was about to return the V-Link to amazon.com and now I have kept it. Sounds pretty good. I am also demoing Pure Music. Haven't decided which one to buy yet.

Yesterday even with the powered hub, I got it all scratchy and Decibel says Overload or something and then I got a kernel panic. Weird.

flohmann
Posts: 1
Joined: Fri Aug 05, 2011 5:31 am

Re: Hog mode and clicking problem

Post by flohmann » Fri Aug 05, 2011 5:35 am

Same problem for me using a mid-2007 20" iMac 2.0Ghz with 4GB RAM, running into a Halide USB-SPDIF converter (and then into Bel Canto 3.5vb DAC). Seems like this is a hardware problem on the Macs of this era. Had the same experience trying to run USB into a Wyred 4 Sound DAC2, as well.

Post Reply