AAC VBR isn't using VBR?

Ask questions and get answers on how to make Max behave.
Post Reply
Posts: 1
Joined: Wed Mar 07, 2007 5:12 am

AAC VBR isn't using VBR?

Post by soob »

Hello all,

I'm trying to encode an aiff into AAC (using MPED4 Audio (Core Audio) format, the one with AAC and Lossless as format choices) with High Quality, 192 Kbps, VBR, but the resulting file reports 192 as the bitrate in iTunes (and I think the file size supports that). Using roughly the same settings with the LAME encoder produces a file with ~110 bitrate (and considerably less filesize).

Am I doing something wrong?

Thanks, Jim
Posts: 201
Joined: Thu Sep 21, 2006 3:55 pm

Post by Mike1 »

No, you're not.

As I understand it, if with the AAC encoder you select VBR then the encoder will give you a higher bitrate in passages where that's deemed desirable but won't drop the bitrate where it really would be desirable (from the POV of economy of filesize) to do so. The set bitrate acts as a kind of floor.

The LAME MP3 encoder is much more flexible in this regard. I get widely varying bitrates for LAME-encoded MP3s depending on the demands of the track I'm encoding. For example, I've got some historic recordings of Andres Segovia playing the guitar and they're in mono sound. LAME has encoded these at around 100kbps. However, LAME has given some other tracks I've got of Christophe Roussett playing the harpsichord at over 200kbps.

As a cross-check, try ripping a track or two from a different CD with LAME and see if you get a higher bitrate with a different piece of music.

I'd speculate that if LAME when set to "Transparent" is encoding the tracks you've got at around the bitrate you're getting, that's all they need, and you might try dropping the bitrate for the AAC encoder down till you get a filesize comparable to what you're getting with LAME. You could try varying the settings and seeing whether there is a discernible diiference in sound-quality and make your choice based on what trade-off beteween quality and filesize seems desirable to you.
Post Reply