it just sits there...

Ask questions and get answers on how to make Max behave.
Post Reply
Posts: 2
Joined: Tue Oct 24, 2006 1:45 am

it just sits there...

Post by emilio » Tue Oct 24, 2006 2:29 am


i've found Max to be a very good encoder solution, especially with the ability to rip multiple formats with a click.

there have been a few strange issues with 0.6.1, but just minor irritations like it "missing" the CD or being unable to eject it. those problems were usually solved with a relaunch, quitting iTunes, or, at worst, deleting the prefs.

now Max has ceased to rip and encode, and it's a bit baffling. my configuration is Max 0.6.1, OS 10.4.8, PM G5.

the basic issue is that i select tracks, click "Encode" and it just sits there with the button grayed out
- the ripper and encoder windows never show any activity, nor does a process monitor.
- clicking the "Eject" button warns me that a task is underway, and can successfully eject the CD.
- other tasks seem unaffected, such as changing preferences, manipulating track data, and so forth.
- i haven't tried converting audio.

stuff i've tried, in many combinations:
- deleting the prefs.
- i usually rip 256k CBR MP3 and FLAC level 5; selecting just one or the other does the same thing (i haven't tried other formats, as i don't use any other formats).
- changing from the comparison ripper to the basic.
- quitting iTunes before launching Max.
- inserting the CD before and after launching Max.
- downloading a fresh copy of 0.6.1.
- Max 0.6.2b
- downloading the krmathis 762 build, mentioned in this post, but the link is dead.

monitoring console.log, system.log, and my user's log doesn't reveal any messages. Max's internal log file does not seem to offer much help, as it starts with the messages i usually see when it's successful:
2006-10-23 18:53:44 -0700 Max successfully launched
2006-10-23 18:53:45 -0700 Found CD on device disk4
2006-10-23 18:53:53 -0700 Unable to read the disc's media catalog number (MCN)
2006-10-23 18:53:53 -0700 Unable to read the international standard recording code (ISRC) for track 1
i suppose i could try restarting the whole computer... but that's more of a last-ditch thing, i'd say. one strange phenomena occurs when running it from a separate drive (separate system/app and user drives); if i run it out of my download folder, ~/Downloads/Max-0.6.1/, i get the TOC read error dialog, while running it from /Applications/Video-Audio/Max-0.6.1/ produces the behavior above.

as an aside, 0.6.2b looks tasty. the preferences rearrangement in the current version was GREAT, and it continues to improve. i would love to see an option for automatic log file saving, like cover art, including a name template and RTF or plain text format preference.

- emilio

User avatar
Site Admin
Posts: 2450
Joined: Fri Dec 23, 2005 7:45 am
Location: USA

Post by sbooth » Tue Oct 24, 2006 6:59 am

This sounds like it could be related to the CDTOC problem. I would go ahead and use the "unstable" version from the website if 0.6.1 is giving you problems.

Posts: 2
Joined: Tue Oct 24, 2006 1:45 am

Post by emilio » Tue Oct 24, 2006 8:34 pm

strangely, 0.6.2b 1038 didn't work the first time around. it seemed to have problems with the preferences (which i tried deleting... i think) and with 0.6.1 .cdinfo files (even crashed once when saving an old .cdinfo) so i never even got to trying an actual encode.

on your suggestion, i tried again with a fresh prefs file and didn't use any of the old .cdinfo files. it worked as expected (i.e. fantastically) for simultaneous MP3 256k CBR and FLAC L5 rips. it was all so baffling because i wasn't always seeing the error message that many others seem to get (or any error, really).

it's still a lightning-fast encoder; huzzah for dual processors and multithreaded applications! comparison rips are still excruciatingly slow and CPU-intensive - seeming much slower than iTunes rips with error correction (and even slower than 0.6.1?) - but maybe that's just if i'm sitting here watching it...

along with the auto-logfile saving, i'd also like to suggest some optional geeky information columns in the ripper and encoder windows, such as write bit/byte throughput and realtime multiplier (1.5X, 6X, etc). it would be nice to have some easily-accessibly and quantifiable feedback on the speed and efficiency of different ripper and encoder settings.

thanks, and i didn't even have to restart!
- emilio

Post Reply