Page 1 of 1

meta data not transferring with add to library

Posted: Mon Mar 09, 2009 12:41 am
by phrarod
I have everything in iTunes and when I navigate to the folders I want import it does so without importing the meta data. The files are AIFF and ripped through iTunes. There's no manual so I'm stumped.

Re: meta data not transferring with add to library

Posted: Mon Mar 09, 2009 5:14 am
by sbooth
Play doesn't currently support ID3 chunks in AIFF files, so there is no way to read metadata from them. Honestly, I'm not 100% positive that iTunes evens embeds ID3 chunks. In any case, Play will do this in the next release.

Re: meta data not transferring with add to library

Posted: Mon Mar 09, 2009 6:03 am
by phrarod
Thanks for the reply.

Two questions: Do you have any ETA on the next release? Why is play sooooooo much better at playback than iTunes even though I rip with iTunes. Its night and day with Play compared to iTunes playback.

Re: meta data not transferring with add to library

Posted: Mon Mar 09, 2009 12:17 pm
by sbooth
I'm terrible at guessing release dates, so I won't even try! I have a ton of ideas for things to do with Play, so I wouldn't expect anything in the next few months.

Re: meta data not transferring with add to library

Posted: Mon Mar 09, 2009 3:54 pm
by RonaldPR
phrarod wrote:Why is play sooooooo much better at playback than iTunes even though I rip with iTunes. Its night and day with Play compared to iTunes playback.
Does playback sound better in Play compared to iTunes? Try disabling "Sound Enhancer" in iTunes, Preferences > Playback.

Re: meta data not transferring with add to library

Posted: Mon Mar 09, 2009 3:56 pm
by phrarod
It sounds TREMENDOUSLY better. Nothing is checked in the iTunes playback section. It sounds so much better I would love to understand why.