Page 1 of 1

Mp3s not playing on Mavericks (10.9.5)

Posted: Fri Jan 23, 2015 9:18 pm
by psilush
Hello, just downloaded this app and would love to use it as my main media player. iTunes is just too heavy and this seems really lightweight in comparison. I've loaded my entire music library into the program though nothing seems to play. I've tried at least 100 different songs, most were mp3s but tried a few .wav files as well. Volume is up (durrr), edited a few things in the preferences hoping for something, though nothing will play at all.

Any help?Image

Re: Mp3s not playing on Mavericks (10.9.5)

Posted: Sun Jan 25, 2015 12:18 am
by sbooth
Is there any output in Console indicating what went wrong? I can't think of a reason why Play wouldn't work on Mavericks but I haven't tested it.

Re: Mp3s not playing on Mavericks (10.9.5)

Posted: Sun Jan 25, 2015 8:51 pm
by psilush
Last login: Sun Jan 25 12:38:34 on ttys000
BoNBoN@Mystery:~% /Applications/Play.app/Contents/MacOS/Play ; exit;
2015-01-25 12:46:43.652 Play[1658:303] Illegal audio unit passed to setAudioUnit
2015-01-25 12:47:00.147 Play[1658:303] -[NSConcreteAttributedString initWithString:] called with nil string argument. This has undefined behavior and will raise an exception in post-Leopard linked apps. This warning is displayed only once.
2015-01-25 12:47:44.259 Play[1658:303] AudioUnitReset failed
2015-01-25 12:47:44.578 Play[1658:303] Bad _contents: nan
2015-01-25 12:47:44.579 Play[1658:303] Bad _contents: nan

12:47:00.147 is where I clicked on a song to try playing it, the other warning just before that happens right when I open the application.

Came across this thread via Google (specifically searched for that "nan" error), tried unchecking the "Rescan" option but still nothing.

http://forums.sbooth.org/viewtopic.php?f=12&t=2361

Any ideas/suggestions?

Edit: Also came across this post which might help. http://forums.sbooth.org/viewtopic.php?f=12&t=4819. Someone mentioned they "fixed" it by bypassing something or other. I have no idea what they did, though I can see what they're referring to in the file mentioned.