Replaygain...

Discuss Play, an open source multi-format audio player.
ddoonie
Posts: 14
Joined: Sat Feb 02, 2008 10:21 am

Re: Replaygain...

Post by ddoonie » Sun Feb 10, 2008 4:17 am

Sorry about that!! I just checked the site, and the new version appears to be up, but is not on your servers? I tried to download, but it's not there...

User avatar
sbooth
Site Admin
Posts: 2447
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Re: Replaygain...

Post by sbooth » Sun Feb 10, 2008 5:58 am

I mangled the extension- all should be fixed now.

ddoonie
Posts: 14
Joined: Sat Feb 02, 2008 10:21 am

Re: Replaygain...

Post by ddoonie » Sun Feb 10, 2008 7:25 am

I tried it out again, to no avail... same result, i get the album gain, but not the track gain. If i could read (or knew how), the rva2 frame, i would try to help spot the differences between how the replaygain info is written... I uploaded two files to my site, one scanned with play the other foobar, http://www.srcpro.com/2.html

Hope this is of some use to you...

ddoonie
Posts: 14
Joined: Sat Feb 02, 2008 10:21 am

Re: Replaygain...

Post by ddoonie » Sun Feb 10, 2008 10:00 am

ok i got some info back from the rockbox guys, and it may be simpler than i thought... Basically, foobar doesn't write ANY RVA2 frames... Since you were writing one rva2 frame, this was taking precedence over the TXXX Frames. So in short, all should be fine, IF it didnt write any rva2 frames..

this from rockbox guys

"Foobar just writes TXXX frames, whereas Play writes TXXX and RVA2 frame(s). Rockbox supports both, but doesn't handle the Play RVA2 frames right. Because the RVA2 frame(s) comes after the TXXX frames, you get the problem."

Regarding the RVA2 frame, i was referred to this document, http://www.sacredchao.net/quodlibet/wiki/Specs/ID3

Essentially that the frame should just be "album" and "track" not replaygain_album_gain etc...

Hope that makes more sense. Never has something so 'simple' been so annoying!

DArryl

User avatar
sbooth
Site Admin
Posts: 2447
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Re: Replaygain...

Post by sbooth » Sun Feb 10, 2008 4:07 pm

This is definitely helpful information, but now that I have it I believe this is probably a deficiency in RockBox, not Play. With the changes I've checked in renaming the RVA2 frames to "track" and "album" (r1077), Play now writes both TXXX and RVA2 frames correctly for both track and album gain.

Do you know what it is about the RVA2 frames Play generates that RockBox doesn't handle correctly? Now that they have the correct identifiers (album and track) I don't see why there would be an issue.

ddoonie
Posts: 14
Joined: Sat Feb 02, 2008 10:21 am

Re: Replaygain...

Post by ddoonie » Sun Feb 10, 2008 7:02 pm

no, i believe the fraim should be just "album" and not "replaygain_album_gain", and "track" and not "replaygain_track_gain". The deficiency with rockbox was that they were only reading one rva2 frame anyways. They have fixed that in the new build already to allow for both.

ddoonie
Posts: 14
Joined: Sat Feb 02, 2008 10:21 am

Re: Replaygain...

Post by ddoonie » Sun Feb 17, 2008 7:57 am

Just doing a follow up to see if you had any further advancements...

Post Reply