Discuss Play, an open source multi-format audio player.
Post Reply
Posts: 201
Joined: Thu Sep 21, 2006 3:55 pm


Post by Mike1 »

I put r932 on a machine that didn't have a previous copy of Play on it, but when I tried to start it, Play threw an error (something to do with the SQL database) and quit. I couldn't launch it.

I tried installing the stable version first and then updating it by dragging r932 into ~/Applications afterwards. After that, r932 would launch.

I'm somewhat ashamed to post this, since I didn't write down the error at the time. But if it'll help, I can always delete the application and all supporting files, try to begin again from scratch with r932, and post a note of the error message if it recurs.
Posts: 433
Joined: Tue May 30, 2006 8:27 am
Location: Amsterdam, Netherlands

Re: r932

Post by RonaldPR »

The error will appear when no earlier file ~/Library/Application Support/Play/Library.sqlite3 is present. Play installs the file when launched for the first time, but apparently there is a problem in r932.

User avatar
Site Admin
Posts: 2458
Joined: Fri Dec 23, 2005 7:45 am
Location: USA

Re: r932

Post by sbooth »

I guess I was so concerned with whether the library update would work that I forgot to check what would happen if there wasn't a library. I've checked in a fix and will post a working unstable shortly. Thanks for letting me know!
Post Reply