Max 0.8 rc2

Discuss the current and future development of Max.
Locked
User avatar
sbooth
Site Admin
Posts: 2445
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Max 0.8 rc2

Post by sbooth » Tue Mar 25, 2008 10:10 pm

I've just posted r1357 as Max 0.8 rc2. The crashing issue on Tiger is fixed, hopefully.

RonaldPR
Posts: 433
Joined: Tue May 30, 2006 8:27 am
Location: Amsterdam, Netherlands

Re: Max 0.8 rc2

Post by RonaldPR » Wed Mar 26, 2008 10:42 am

No crash, but an error message: "The call to ExtAudioFileGetProperty failed."

I tried to convert a flac file to apple lossless.

When accessing the File menu I get in Console:

Code: Select all

2008-03-26 11:31:42.377 Max[461] *** Illegal NSTableView data source (<FileArrayController: 0x11c0700>[object class: NSMutableDictionary, number of selected objects: 0]).  Must implement numberOfRowsInTableView: and tableView:objectValueForTableColumn:row:
When clicking the 'Convert' icon in the File Conversion window I get the above error message, and in Console:

Code: Select all

2008-03-26 11:32:16.144 Max[461] *** Assertion failure in -[CoreAudioEncoder encodeToFile:], /Users/sbooth/Development/Max-svn/Encoders/CoreAudioEncoder.m:190
Seems Max is looking for CoreAudioEncoder on your computer. :wink:

(Max-r1357 and Mac OS X 10.4.11 on alu Intel iMac)

User avatar
sbooth
Site Admin
Posts: 2445
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Re: Max 0.8 rc2

Post by sbooth » Wed Mar 26, 2008 3:07 pm

I've fixed the first error.

I'm not sure why the second error is an error- are there any other messages in the console log (ie, the call to XXX failed)?

RonaldPR
Posts: 433
Joined: Tue May 30, 2006 8:27 am
Location: Amsterdam, Netherlands

Re: Max 0.8 rc2

Post by RonaldPR » Wed Mar 26, 2008 9:07 pm

I posted the console log above. There are no other messages. I am no expert, but does the second message not indicate that Max is looking in a location that is specific for your Mac only: /Users/sbooth/Development/Max-svn/Encoders/ ?

User avatar
sbooth
Site Admin
Posts: 2445
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Re: Max 0.8 rc2

Post by sbooth » Wed Mar 26, 2008 9:29 pm

No, it's just the path to the source file that was hardcoded in by a macro at compile time. It does help to locate the line number that is causing the error, but I can't duplicate it.

RonaldPR
Posts: 433
Joined: Tue May 30, 2006 8:27 am
Location: Amsterdam, Netherlands

Re: Max 0.8 rc2

Post by RonaldPR » Wed Mar 26, 2008 10:05 pm

Tried again, this time ripping a CD to Apple Lossless. Ripping proceeds fine, but when encoding should start I get the exact same error message and the exact same message in Console. Nothing else

RonaldPR
Posts: 433
Joined: Tue May 30, 2006 8:27 am
Location: Amsterdam, Netherlands

Re: Max 0.8 rc2

Post by RonaldPR » Wed Mar 26, 2008 10:27 pm

I dug up Max 0.7.1. The same conversion to apple lossless of the same flac file that I tried this morning succeeded with no problem.

mugnebot
Posts: 4
Joined: Wed May 30, 2007 9:19 pm

Re: Max 0.8 rc2

Post by mugnebot » Thu Mar 27, 2008 10:07 pm

This build crashes for me when encoding to FLAC. Encoding to MP3 is working as is FLAC with stable version (0.7). Would you like to see a crash log or is there anything else that might help?

RonaldPR
Posts: 433
Joined: Tue May 30, 2006 8:27 am
Location: Amsterdam, Netherlands

Re: Max 0.8 rc2

Post by RonaldPR » Thu Mar 27, 2008 10:41 pm

No problems while encoding to FLAC here. (10.4.11 on Intel)

User avatar
sbooth
Site Admin
Posts: 2445
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Re: Max 0.8 rc2

Post by sbooth » Fri Mar 28, 2008 2:29 am

If you upgraded from 0.7.1 it is necessary to delete your preferences before running 0.8.

droflaneb
Posts: 2
Joined: Fri Mar 21, 2008 7:48 am

Re: Max 0.8 rc2

Post by droflaneb » Fri Mar 28, 2008 5:00 pm

sbooth wrote:I've fixed the first error.

I'm not sure why the second error is an error- are there any other messages in the console log (ie, the call to XXX failed)?
A message will pop up and say "The call to ExtAudioFileGetProperty failed."

Image

mathom
Posts: 10
Joined: Sat Feb 09, 2008 7:07 pm

Re: Max 0.8 rc2

Post by mathom » Sat Mar 29, 2008 3:58 pm

The same happens to me.

Code: Select all

2008-03-29 16:49:25.656 Max[234] *** Assertion failure in -[CoreAudioEncoder encodeToFile:], /Users/sbooth/Development/Max-svn/Encoders/CoreAudioEncoder.m:190
Attachments
Bild 1.png

User avatar
sbooth
Site Admin
Posts: 2445
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Re: Max 0.8 rc2

Post by sbooth » Sat Mar 29, 2008 5:56 pm

This could be a Tiger-specific bug. I am having no issues with this on my Leopard machine, but I will keep investigating.

DaedalusX
Posts: 1
Joined: Fri Apr 04, 2008 5:17 pm

Re: Max 0.8 rc2

Post by DaedalusX » Fri Apr 04, 2008 9:31 pm

Note: This is a problem with a workaround, but I thought I'd bring it up just the same.

I'm running Leopard 10.5.2 and Max 0.8 RC2. I'm trying to rip and encode to AAC. The encode goes fine, but then I get this error:
Picture 1.png
Console.app shows this:

Code: Select all

4/4/08 5:13:46 PM Max[8653] *** Assertion failure in generateTemporaryFilename(), /Users/sbooth/Development/Max-svn/Utilities/UtilityFunctions.m:516 
4/4/08 5:13:56 PM Max[8653] *** Assertion failure in generateTemporaryFilename(), /Users/sbooth/Development/Max-svn/Utilities/UtilityFunctions.m:516 
4/4/08 5:13:59 PM Max[8653] *** Assertion failure in generateTemporaryFilename(), /Users/sbooth/Development/Max-svn/Utilities/UtilityFunctions.m:516 
4/4/08 5:14:02 PM Max[8653] *** Assertion failure in generateTemporaryFilename(), /Users/sbooth/Development/Max-svn/Utilities/UtilityFunctions.m:516 
4/4/08 5:15:27 PM Max[8653] Max(8653,0xb06d3000) malloc: *** error for object 0x17f5c250: double free
*** set a breakpoint in malloc_error_break to debug 
4/4/08 5:15:27 PM Max[8653] *** Assertion failure in -[CoreAudioEncoder encodeToFile:], /Users/sbooth/Development/Max-svn/Encoders/CoreAudioEncoder.m:110 
4/4/08 5:15:27 PM [0x0-0x111111].org.sbooth.Max[8653] Max(8653,0xb06d3000) malloc: *** error for object 0x17f5c250: double free 
4/4/08 5:15:27 PM [0x0-0x111111].org.sbooth.Max[8653] *** set a breakpoint in malloc_error_break to debug 
My custom tagging setting is this: {albumArtist}/{albumTitle}/{trackNumber} - {trackTitle}

It creates the initial rip file, the album artist folder and the album title subfolder, but doesn't create the file beneath those. It later occurred to me that I had both Apple Lossless and AAC configured and checked under Preferences->Formats, so it was trying to encode both files to the same path with the same names.

If I uncheck one or the other, I have no troubles. This is more of a UI issue than a technical issue, but it's an edge case without an obvious cause/solution for the user. Just thought I'd mention it.

Other than that, just wanted to stop in and say that you make one hell of a program. :mrgreen:

Locked

Who is online

Users browsing this forum: No registered users and 1 guest