Max and Mac OS 10.5 issue...

Discuss the current and future development of Max.
User avatar
krmathis
Posts: 233
Joined: Thu Feb 02, 2006 11:05 am
Location: Oslo, Norway

Max and Mac OS 10.5 issue...

Post by krmathis » Thu Sep 27, 2007 3:52 pm

I have just installed the latest Mac OS 10.5 (build 9a559), and have noticed a problem with Max r1213.
Its impossible to access Preference -> Formats. I click the 'Formats' icon, but nothing happens.

Ok, I know that Mac OS 10.5 is not released yet and hence not supported. But wanted to report in case its not a known issue, or even better have an easy fix.
Thanks!

User avatar
sbooth
Site Admin
Posts: 2445
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Re: Max and Mac OS 10.5 issue...

Post by sbooth » Thu Sep 27, 2007 4:38 pm

I won't have access to Leopard until it comes out; I will fix these issues as soon as I can, though.

User avatar
krmathis
Posts: 233
Joined: Thu Feb 02, 2006 11:05 am
Location: Oslo, Norway

Re: Max and Mac OS 10.5 issue...

Post by krmathis » Thu Sep 27, 2007 6:21 pm

I totally understand.
Only a months or so to go, so I am pretty sure I can manage without Max for this short time.

User avatar
krmathis
Posts: 233
Joined: Thu Feb 02, 2006 11:05 am
Location: Oslo, Norway

Re: Max and Mac OS 10.5 issue...

Post by krmathis » Fri Oct 26, 2007 10:58 pm

Any news?
Now that Mac OS 10.5 is golden I mean. Even if its only few hours old... :p

I am so missing Max!

User avatar
sbooth
Site Admin
Posts: 2445
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Re: Max and Mac OS 10.5 issue...

Post by sbooth » Fri Oct 26, 2007 11:39 pm

krmathis wrote:Any news?
Now that Mac OS 10.5 is golden I mean. Even if its only few hours old... :p

I am so missing Max!
I have just unwrapped my copy of 10.5, and I'll be installing it this evening. I'll take a look at what will be required to get Max working on Leopard over the weekend.

User avatar
Lazenby
Posts: 2
Joined: Fri Oct 26, 2007 11:47 pm

Re: Max and Mac OS 10.5 issue...

Post by Lazenby » Fri Oct 26, 2007 11:53 pm

Are we certain build 1273 doesn't work on Leopard? I couldn't get any of the earlier builds to compile with XCode 2.5 (understandable), but 1273 suddenly does and the Max app it produces seems to work flawlessly on 10.4.10. I would check if build 1273 built with XCode 3 ran on Leopard...

User avatar
krmathis
Posts: 233
Joined: Thu Feb 02, 2006 11:05 am
Location: Oslo, Norway

Re: Max and Mac OS 10.5 issue...

Post by krmathis » Sat Oct 27, 2007 1:02 am

sbooth wrote:I have just unwrapped my copy of 10.5, and I'll be installing it this evening. I'll take a look at what will be required to get Max working on Leopard over the weekend.
Excellent!
I really appreciate the work you put into developing this application. :D

jdc0730
Posts: 6
Joined: Sat Oct 27, 2007 10:24 am

Re: Max and Mac OS 10.5 issue...

Post by jdc0730 » Sat Oct 27, 2007 10:27 am

I am sure you will find this out soon enough, but clicking on "Formats" generates the following error in Console:

Code: Select all

10/26/07 10:00:18 PM Max[452] *** Assertion failure in getCoreAudioFileDataFormats(), /Users/me/Development/Max-svn/Utilities/CoreAudioUtilities.m:206 
10/26/07 10:00:18 PM Max[452] The call to AudioConverterSetProperty failed (!dat).
Thanks for the great work.
Jeff

User avatar
sbooth
Site Admin
Posts: 2445
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Re: Max and Mac OS 10.5 issue...

Post by sbooth » Mon Oct 29, 2007 3:58 am

I've gotten Max to run on 10.5, but I have run into an alarming issue that I believe is a bug outside of Max. I am currently investigating the cause.

I've checked all changes into svn for anyone interested in rolling a test version.

eriksyring
Posts: 1
Joined: Mon Oct 29, 2007 4:45 pm

Re: Max and Mac OS 10.5 issue...

Post by eriksyring » Mon Oct 29, 2007 4:57 pm

For me Max 0.7.1 quits when attempted run on 10.5, at least for FLAC->m4a conversion...

User avatar
sbooth
Site Admin
Posts: 2445
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Re: Max and Mac OS 10.5 issue...

Post by sbooth » Mon Oct 29, 2007 5:01 pm

eriksyring wrote:For me Max 0.7.1 quits when attempted run on 10.5, at least for FLAC->m4a conversion...
That is the bug I alluded to; conversions to MPEG-4 don't work, but all others do. You'll likely get a crash similar to the following:

Code: Select all

#0	0x91ee92a8 in MP4BoxParser_Track::GetInfoFromTrackSubBoxes
#1	0x91ee99fc in MP4BoxParser_Track::GetASBD
#2	0x91ee0410 in MP4AudioFile::GetFormatListInfo
#3	0x91e9bbf4 in AudioFileObject::GetPropertyInfo
#4	0x91e9a744 in AudioFileGetPropertyInfo
#5	0x91eaed04 in ExtAudioFile::GetExistingFileInfo
#6	0x91eb04c0 in ExtAudioFile::Wrap
#7	0x91ea4e18 in ExtAudioFileWrapAudioFileID
#8	0x00002768 in -[MyDocument action:] at MyDocument.m:102
#9	0x9380835c in -[NSApplication sendAction:to:from:]
#10	0x93808290 in -[NSControl sendAction:to:]
#11	0x938077a8 in -[NSCell trackMouse:inRect:ofView:untilMouseUp:]
#12	0x938070e0 in -[NSButtonCell trackMouse:inRect:ofView:untilMouseUp:]
#13	0x93806a1c in -[NSControl mouseDown:]
#14	0x93805458 in -[NSWindow sendEvent:]
#15	0x937d88f4 in -[NSApplication sendEvent:]
#16	0x93745ed8 in -[NSApplication run]
#17	0x93716930 in NSApplicationMain
#18	0x00002bd8 in main at main.m:13
The same code works properly in 10.4; I'm still trying to determine if the bug is mine or Apple's.

User avatar
krmathis
Posts: 233
Joined: Thu Feb 02, 2006 11:05 am
Location: Oslo, Norway

Re: Max and Mac OS 10.5 issue...

Post by krmathis » Mon Oct 29, 2007 5:04 pm

I have Max rev. 1276 up and running on Mac OS 10.5.
The 'Format' tab now opens fine. Not performed any ripping/encoding yet though.

Thanks! :D

User avatar
Lazenby
Posts: 2
Joined: Fri Oct 26, 2007 11:47 pm

Re: Max and Mac OS 10.5 issue...

Post by Lazenby » Tue Oct 30, 2007 5:11 am

sbooth wrote:conversions to MPEG-4 don't work, but all others do
I actually can't convince Max to encode, as I get a "No output formats are selected. Please select one or more output formats." error even though I've picked some formats and checked them as active. Also, when I select the AAC format, it specifically states "1 channels" and initially suggests 64 kbps. Maybe I'm missing something? Or my Leopard install is a freak of nature?

By the way, Stephen, Max is a wonderful program. Now that I've had it, I can't live without it.
Cheers!

rollooo72
Posts: 2
Joined: Tue Oct 30, 2007 6:09 pm

Re: Max and Mac OS 10.5 issue...

Post by rollooo72 » Tue Oct 30, 2007 6:13 pm

I have Max rev. 1276 up and running on Mac OS 10.5.
I have the same "formats tab" problem with Leopard. Where did you get MAX rev 1276?

dcorry
Posts: 2
Joined: Wed Oct 31, 2007 3:37 am

Re: Max and Mac OS 10.5 issue...

Post by dcorry » Wed Oct 31, 2007 3:49 am

I built rev 1276 (by doing a svn co -r 1276), and the menu 'works'. The menu opens, but I still get that error.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests