filename problem

Discuss Max, an open source CD audio extractor and audio converter.
Post Reply
jjones
Posts: 3
Joined: Wed Feb 18, 2009 4:05 pm

filename problem

Post by jjones » Wed Feb 18, 2009 4:11 pm

Hi,
I'm using {albumArtist}/{albumTitle}/{trackNumber} {trackTitle} in the prefrences whilst converting an .ape/.cue to mp3. But my resulting filenames are always {albumTitle}/{trackNumber}.mp3. What am i doing wrong?


Thanks!

Mike1
Posts: 201
Joined: Thu Sep 21, 2006 3:55 pm

Re: filename problem

Post by Mike1 » Wed Feb 18, 2009 4:27 pm

jjones wrote:Hi,
I'm using {albumArtist}/{albumTitle}/{trackNumber} {trackTitle} in the prefrences
The default, IOW.
But my resulting filenames are always {albumTitle}/{trackNumber}.mp3.
While, like you, I don't change the default, I've found I have to check the "Use a custom format ..." box just above that. I don't know why, but it seems I need to. If I don't Max doesn't create an albumArtist directory but drops the albumTitle directory and contents in "Compilations".

Have you got that box checked?

jjones
Posts: 3
Joined: Wed Feb 18, 2009 4:05 pm

Re: filename problem

Post by jjones » Fri Feb 20, 2009 6:00 am

Indeed I've checked the 'custom' box.

Mike1
Posts: 201
Joined: Thu Sep 21, 2006 3:55 pm

Re: filename problem

Post by Mike1 » Fri Feb 20, 2009 8:20 am

jjones wrote:Indeed I've checked the 'custom' box.
That was the only thought I had. I suppose it might be a problem specific to the formats then - or, alternatively, that the .cue file is not as it should be.

I know Monkey's Audio has its own tagging system. I don't know what the .cue file should look like. Maybe you could open it in a text editor and post it, or a sample of it, here. There may be someone reading here who could look at it.

jjones
Posts: 3
Joined: Wed Feb 18, 2009 4:05 pm

Re: filename problem

Post by jjones » Fri Feb 20, 2009 5:45 pm

cool. I'll take a look for the sake of the project. Certainly not any easier than renaming files. ;)

Paul Gotch
Posts: 23
Joined: Mon Oct 30, 2006 10:54 pm

Re: filename problem

Post by Paul Gotch » Sun Apr 05, 2009 5:11 pm

You aren't doing anything wrong there is a long standing bug which means that Max ignores AlbumArtist tags for the purposes of output directories when converting see

http://trac.sbooth.org/Max/ticket/8

User avatar
sbooth
Site Admin
Posts: 2445
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Re: filename problem

Post by sbooth » Sun Apr 05, 2009 5:13 pm

Does this happen with Max-r1381?

Paul Gotch
Posts: 23
Joined: Mon Oct 30, 2006 10:54 pm

Re: filename problem

Post by Paul Gotch » Sun Apr 12, 2009 9:13 pm

It does happen with the 1381 build, the binary I have dates from the 11th October 2008.

There is actually a patch attached to the defect that that I linked to but I haven't looked at it to see if it's any good. I've actually just run into this bug myself after wanting to reconvert all my music to a lower bit rate for my iPhone. I was going to fix it locally, the amount of effort I put into it depends though on how likely patches are to be merged back. That bug I linked to with a patch was raised 12 months ago and was last modified 7 months ago.

Post Reply