Page 1 of 1

Some MP3 without sound in version 1.3.2

Posted: Mon Apr 06, 2015 9:50 am
by fahne
With the new version (1.3.2), there are some MP3 files that seem to play normally, except that there is no output sound whatsoever. They play fine in 1.2.11. What can I do?

Re: Some MP3 without sound in version 1.3.2

Posted: Sun Nov 29, 2015 2:49 am
by sbooth
Would you be able to share one with me via DropBox?

Re: Some MP3 without sound in version 1.3.2

Posted: Thu Dec 03, 2015 1:52 pm
by gyepi
Stephen,

I sent you an email about this problem on the 30th of June, 2015, with an example .mp3 file attached. The problem seems to be with mp3 files which have only 1 channel (instead of the usual 2). If you want to play such a file with Decibel, the player shows the progress but no audio output is produced.

The same problem persists in version 1.3.3. Please fix it. Ever since discovering this bug (unfortunately during a live event) I need to nervously check the number of channels when I drop a file on Decibel.

By the way the "add selection" crash I reported back in 2014 in version 1.3.2 seems to be finally fixed in 1.3.3, thanks. (It still boggles my mind why we need this work-around when we want to import several files to preserve playlist order; I've yet to encounter another music player that messes up the play order when a selection is drag-and-dropped.)

Thanks.

Re: Some MP3 without sound in version 1.3.2

Posted: Thu Dec 03, 2015 11:24 pm
by sbooth
The way Decibel currently works with mono files is to map the output channels using the multichannel speaker mappings (in Audio MIDI Setup). The stereo mappings are only used for 2 channel files. It probably makes more sense to automatically remap mono files to the stereo output channels automatically.

Decibel keeps the playlist sorted according to the current sort descriptors. If you remove them, selection drags shouldn't be reordered.