unwanted pauses in middle of tracks

Discuss Decibel, a high quality audio player.
mattn
Posts: 152
Joined: Tue Sep 02, 2008 4:21 am

Re: unwanted pauses in middle of tracks

Post by mattn » Sat Dec 29, 2012 2:50 am

Even with these settings I experience the issue:

Code: Select all

    RingBufferCapacity = 32768;
    RingBufferWriteChunkSize = 4096;
I just got this in the Console:

Code: Select all

Insufficient audio in ring buffer: 332 frames available, 512 requested
So whatever Decibel ships with needs to be bigger than that. I'll double again and see what happens.

User avatar
sbooth
Site Admin
Posts: 2445
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Re: unwanted pauses in middle of tracks

Post by sbooth » Sat Dec 29, 2012 5:12 pm

Any values specified manually from Console using the keys RingBufferCapacity or RingBufferWriteChunkSize will take precedence over the Use larger buffer sizes checkbox in the preferences.The default buffer size is now 16384 and the default write chunk size is 2048. If the larger buffer option is enabled these values are doubled.

mattn
Posts: 152
Joined: Tue Sep 02, 2008 4:21 am

Re: unwanted pauses in middle of tracks

Post by mattn » Fri Jan 04, 2013 3:28 am

sbooth wrote:Any values specified manually from Console using the keys RingBufferCapacity or RingBufferWriteChunkSize will take precedence over the Use larger buffer sizes checkbox in the preferences.The default buffer size is now 16384 and the default write chunk size is 2048. If the larger buffer option is enabled these values are doubled.
I just told you that my numbers *are* double those values but I'm still having the problem. What I'm suggesting is that you need to double your default (and double your double).

mattn
Posts: 152
Joined: Tue Sep 02, 2008 4:21 am

Re: unwanted pauses in middle of tracks

Post by mattn » Sun Jan 06, 2013 12:10 am

Okay, I just had the problem *again*, with a pause in the middle of a playing track, and this message in the console:

Code: Select all

1/5/13 4:02:40 PM	Decibel[993]	Insufficient audio in ring buffer: 480 frames available, 512 requested
My prefs are set to Use Larger Buffer Sizes, plus I've set the values manually:

Code: Select all

$ defaults read org.sbooth.Decibel
    ...
    RingBufferCapacity = 65536;
    RingBufferWriteChunkSize = 8192;
    ...
How big do these buffers have to be to rid me of this unwanted phenomenon? This is with Version 1.2.11 (31). Once again I stress that Decibel is a very nice thing, but if you're going to charge money for it, shouldn't this be a concern?

mullet
Posts: 8
Joined: Sun May 14, 2006 1:47 pm

Re: unwanted pauses in middle of tracks

Post by mullet » Thu May 09, 2013 5:35 am

I get the skips constantly. For awhile I thought it was my DAC. I now see I'm not alone. I'm using a DIY AMB labs Gamma 2 that I built. It has 24 192 upsampling so I just turned off the sample rate conversion and I'm going to see if the skips go away. Hopefully, this gets fixed.

mullet
Posts: 8
Joined: Sun May 14, 2006 1:47 pm

Re: unwanted pauses in middle of tracks

Post by mullet » Sat May 11, 2013 10:08 pm

I don't know if anyone tried this and whether this is worth it to you in terms of wanting to use the "Adjust sample rate for best quality" feature, but when turning it off I'm finding the skipping going away. My question is what is the implication of turning off this setting? I'm using "Obtain exclusive access" by the way.

mattn
Posts: 152
Joined: Tue Sep 02, 2008 4:21 am

Re: unwanted pauses in middle of tracks

Post by mattn » Mon Jun 03, 2013 5:48 pm

mullet wrote:I don't know if anyone tried this and whether this is worth it to you in terms of wanting to use the "Adjust sample rate for best quality" feature, but when turning it off I'm finding the skipping going away. My question is what is the implication of turning off this setting? I'm using "Obtain exclusive access" by the way.
Interesting. I'll try unchecking "Adjust sample rate" and see what happens! Thanks for the suggestion.

mullet
Posts: 8
Joined: Sun May 14, 2006 1:47 pm

Re: unwanted pauses in middle of tracks

Post by mullet » Wed Jun 12, 2013 9:46 pm

Ok this is my latest finding and the clicks, dropouts, skipping, silence seems to have gone away. Here's my set up and why I chose these settings. Yours may be different. Like I mentioned before... I turned off "Adjust sample rate for best quality". The reason for this was according to my DACs designer there is no need to adjust sample rate because the DAC has its own ASRC (automatic sample rate converter) to 24/96. I initially thought the skipping went away after unchecking this setting, but it was not completely mitigated. Then I decided to uncheck "Insert silence between sample rate changes" and now the clicking appears to be gone. Not sure why you'd want this feature, but I turned it off because it was getting in the way.

*edit* Looks like I spoke too soon. My findings are completely off. It seemed like the clicks went away, but they're back. I'm just chalking it up to this DIY DAC. I have to test it compared to a new one I'm building, then I can be sure.

tamale
Posts: 18
Joined: Sat Aug 27, 2011 1:22 pm

Re: unwanted pauses in middle of tracks

Post by tamale » Thu Jun 27, 2013 2:33 pm

I'm having exactly the same problem, and it doesn't matter whether I use my external DAC or not, the stuttering is always there. It seems to be worse when media is playing off an external hard drive or from CD. "Adjust sample rate for best quality" does not seem to help. It is possible to stop the problem with "Load files in memory", but that does not work for CD.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest