File Naming settings bug

Discuss Rip, an open source accurate CD audio extractor.
Post Reply
Tuckers
Posts: 1
Joined: Wed Jun 24, 2009 11:53 pm

File Naming settings bug

Post by Tuckers » Thu Jun 25, 2009 9:30 am

I setup a file naming command line like this: {trackGenre}/{albumArtist}/{albumTitle}/{trackNumber} - {trackTitle} - {albumArtist} - {albumTitle} - {trackGenre}

When I ripped an album, the first folder showed up as "{trackGenre}" not the actual genre of the album. The genre does show up at the end of the file name like it's supposed to.

Also when I go to change the file command string it does change, but when I quit Rip and restart, it shows the original file command string above. So it is not sticking. There is nothing being reported to the console during any of these activities.

Also, why do you not have albumGenre as an option here? It is in Max and is very useful The above string is how we setup music libraries by default (except we use albumGenre instead of trackGenre.

User avatar
sbooth
Site Admin
Posts: 2445
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Re: File Naming settings bug

Post by sbooth » Thu Jun 25, 2009 9:38 pm

I will look into the genre issue- it is probably a bug concerning multiple substitution.

As far as the file naming setting not sticking, did you press enter/return/tab after editing? It is likely the text field needs to lose focus for the changes to be saved.

There isn't an albumGenre option because Rip doesn't have the concept of genre for an album- it applies genres only to individual tracks. In most players, a track can have only one genre, so Rip reflects this.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest