None of the Core Audio Encoders Work Correctly

Ask questions and get answers on how to make Max behave.
Post Reply
marc_dc
Posts: 2
Joined: Sun Mar 05, 2006 7:45 am

None of the Core Audio Encoders Work Correctly

Post by marc_dc » Sun Mar 05, 2006 7:49 am

I am having problems encoding music with this program. All I get is white noise. I am using an Intel Mac Mini to encode music. I have tried Apple Lossless, Apple Core Audio, and AIFF formats under the Core Audio encoding option. All of these only generate white noise. I have tried the minimum and maximum quality settings -- no difference.

If I use the built-in encoders (LAME MP3, FLAC), the program works fine.

Is there some type of problem with the program interacting with Core Audio?

User avatar
sbooth
Site Admin
Posts: 2445
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Re: None of the Core Audio Encoders Work Correctly

Post by sbooth » Sun Mar 05, 2006 9:13 am

marc_dc wrote:I am having problems encoding music with this program. All I get is white noise. I am using an Intel Mac Mini to encode music. I have tried Apple Lossless, Apple Core Audio, and AIFF formats under the Core Audio encoding option. All of these only generate white noise. I have tried the minimum and maximum quality settings -- no difference.

If I use the built-in encoders (LAME MP3, FLAC), the program works fine.

Is there some type of problem with the program interacting with Core Audio?
This is something that I have fixed in the source code, but I have not yet released a new version with the changes (I haven't been around for the past few weeks).

If you are so inclined, you can download the nightly snapshot and attempt to build Max yourself. Alternatively, I can send you a beta if you want something that works now- just e-mail me.

Justus
Posts: 9
Joined: Sun Mar 05, 2006 3:09 pm

Re: None of the Core Audio Encoders Work Correctly

Post by Justus » Sun Mar 05, 2006 3:22 pm

sbooth wrote:
marc_dc wrote:I am having problems encoding music with this program. All I get is white noise. I am using an Intel Mac Mini to encode music. I have tried Apple Lossless, Apple Core Audio, and AIFF formats under the Core Audio encoding option. All of these only generate white noise. I have tried the minimum and maximum quality settings -- no difference.

If I use the built-in encoders (LAME MP3, FLAC), the program works fine.

Is there some type of problem with the program interacting with Core Audio?
This is something that I have fixed in the source code, but I have not yet released a new version with the changes (I haven't been around for the past few weeks).

If you are so inclined, you can download the nightly snapshot and attempt to build Max yourself. Alternatively, I can send you a beta if you
want something that works now- just e-mail me.
So the nightly snapshot download is for building Max on your own? I was wondering what that was for.

User avatar
sbooth
Site Admin
Posts: 2445
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Re: None of the Core Audio Encoders Work Correctly

Post by sbooth » Sun Mar 05, 2006 4:03 pm

Justus wrote:So the nightly snapshot download is for building Max on your own? I was wondering what that was for.
Yes, it contains the up-to-the minute source code for people who want to roll their own non-release version of Max.

marc_dc
Posts: 2
Joined: Sun Mar 05, 2006 7:45 am

Post by marc_dc » Tue Mar 07, 2006 11:01 pm

Yay! Beta version 0.5.6 works without a hitch on my Intel Mac. Thanks, Stephen! :D

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest