Numerical Information Added to Track Names

Ask questions and get answers on how to make Max behave.
Post Reply
User avatar
phule
Posts: 46
Joined: Sat Feb 25, 2006 8:26 pm

Numerical Information Added to Track Names

Post by phule » Thu Jun 15, 2006 5:58 pm

After encoding the first CD of a box-set of eight, I found that each track title began with 1 followed by a space then 0n (or the track number) such as "1 05-track name" for track #5.

I this a freedb "feature", info from CD, or bug in Max 0.6.1 :?:
Bob

User avatar
sbooth
Site Admin
Posts: 2445
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Re: Numerical Information Added to Track Names

Post by sbooth » Thu Jun 15, 2006 7:02 pm

phule wrote:After encoding the first CD of a box-set of eight, I found that each track title began with 1 followed by a space then 0n (or the track number) such as "1 05-track name" for track #5.

I this a freedb "feature", info from CD, or bug in Max 0.6.1 :?:
If I recall correctly this is actually a bug in iTunes! But I'd like to narrow it down before I cast the blame elsewhere. Do you have the 'save encoder settings in comment' option selected? I seem to remember that when carriage returns or linefeeds are in the comments field for MP3s, iTunes parses them incorrectly. I've actually filed a bug on this a while back with Apple (problem ID 4491181).

User avatar
phule
Posts: 46
Joined: Sat Feb 25, 2006 8:26 pm

Re: Numerical Information Added to Track Names

Post by phule » Thu Jun 15, 2006 8:31 pm

sbooth wrote:
phule wrote:After encoding the first CD of a box-set of eight, I found that each track title began with 1 followed by a space then 0n (or the track number) such as "1 05-track name" for track #5.

I this a freedb "feature", info from CD, or bug in Max 0.6.1 :?:
If I recall correctly this is actually a bug in iTunes! But I'd like to narrow it down before I cast the blame elsewhere. Do you have the 'save encoder settings in comment' option selected? I seem to remember that when carriage returns or linefeeds are in the comments field for MP3s, iTunes parses them incorrectly. I've actually filed a bug on this a while back with Apple (problem ID 4491181).
Yes, I did have the "save encoder settings in comment" option selected. But where can I find these settings. I encoded the CD as an MP3 and I'm not certain that encoder settings are even saved. I've also noticed that when Max queries freedb, anything entered in the comments field are not transferred to iTunes.
Bob

User avatar
sbooth
Site Admin
Posts: 2445
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Re: Numerical Information Added to Track Names

Post by sbooth » Thu Jun 15, 2006 9:13 pm

phule wrote:Yes, I did have the "save encoder settings in comment" option selected. But where can I find these settings. I encoded the CD as an MP3 and I'm not certain that encoder settings are even saved. I've also noticed that when Max queries freedb, anything entered in the comments field are not transferred to iTunes.
This is a remnant of the iTunes bug as well- if you encode to MP3, before importing the file to iTunes examine the ID3 tags with your favorite ID3 editor. Everything should be as expected. Import it into iTunes, and inspect again- the comments will have been lost and the title will be incorrect.

Turning off the "save encoder settings in comment" usually solves the problem because when the settings are written to the comment a linefeed is added afterward.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests