Max Can't See FLAC Metadata

Ask questions and get answers on how to make Max behave.
Post Reply
digitalox
Posts: 1
Joined: Tue Dec 18, 2007 1:41 am

Max Can't See FLAC Metadata

Post by digitalox » Wed Dec 19, 2007 3:39 am

I ripped my CD collection into FLAC on a PC with EAC.

Now I've got a MacBook Pro and wanted to convert said FLACs to MP4 into the iTunes library. When I open the files with Cog I can see the metadata, but Max sees very little of if it all, like just the Artist or Album. So when I convert them to MP4 they have little/no metadata and end up a big mess in iTunes.

Any ideas on what would cause this? I'm on MacBook Pro w/ Leopard, running Max version 0.8b. Thanks.

Mike1
Posts: 201
Joined: Thu Sep 21, 2006 3:55 pm

Re: Max Can't See FLAC Metadata

Post by Mike1 » Wed Dec 19, 2007 7:29 pm

digitalox wrote:I ripped my CD collection into FLAC on a PC with EAC.

Now I've got a MacBook Pro and wanted to convert said FLACs to MP4 into the iTunes library. When I open the files with Cog I can see the metadata, but Max sees very little of if it all, like just the Artist or Album. So when I convert them to MP4 they have little/no metadata and end up a big mess in iTunes.

Any ideas on what would cause this? I'm on MacBook Pro w/ Leopard, running Max version 0.8b. Thanks.
That's a pain. The metadata for Vorbis Comments, which is what FLAC uses, seems under-specified to say the least, but the track name and number are standard fields that should work anywhere. I wonder: can you see the tags in Tag -- also available from S. Booth's site -- or how about under Windows in Mp3tag?

If you've still got the Windows machine, you might try converting to MP4 on that with Nero and see if the metadata comes through OK using that method. It's easiest done through Foobar2000. You need to have the relevant Nero exes, which are in a free download, in C:\Program Files\NeroDigitalAudio. Foobar2000 should see them. You just open the FLACs in Foobar, right click on them, and choose "Convert", selecting the Nero Encoder in the resulting dialog. You could change the setting so that Nero uses a .m4a extension -- it doesn't by default -- or simply change the file extension afterwards.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest