GnuPG

Discuss macOS Audio in general and anything that doesn't fit elsewhere.
Post Reply
Mike1
Posts: 201
Joined: Thu Sep 21, 2006 3:55 pm

GnuPG

Post by Mike1 » Thu Dec 18, 2008 4:08 pm

Hope this is all right here. Maybe "Discuss OS X Audio in general and anything that doesn't fit elsewhere" doesn't quite cover it [1]. Apologies for posting if not.

I just wondered if anyone knew anything about the current state of GnuPG for Mac.

On the main GnuPG site the current version is 1.4.9:

http://www.gnupg.org/download/

But MacGPG only has a compiled binary for 1.4.8:

http://macgpg.sourceforge.net/

Now I haven't got the developer tools currently installed, otherwise I'd compile 1.4.9 just to be on the safe side. I'm not sure whether it's worth installing them just for this. So - does anyone know if there are any problems with 1.4.8 that mean it positively shouldn't be used? There are some pretty well-informed people here, and I'm betting someone like Mr Mathis, for example, might well know.


[1] The only positively audio connection I could imagine here is if someone on a Mac needed to send audio information to Stephen and encrypt it with his GPG key, and I can't claim I need to do that. :-)

Mike1
Posts: 201
Joined: Thu Sep 21, 2006 3:55 pm

Re: GnuPG

Post by Mike1 » Thu Dec 18, 2008 4:36 pm

So - does anyone know if there are any problems with 1.4.8 that mean it positively shouldn't be used?
Hmmm. A bit more searching and I found out some more. Apparently, 1.4.9 is
a maintenance release to fix a possible vulnerability introduced with 1.4.8.
http://lists.gnupg.org/pipermail/gnupg- ... 00272.html

So I suppose there's no positive reason not to use 1.4.8. Still, I reckon I'll install the tools and build 1.4.9 given that 1.4.8 is possibly problematic.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest