sample rate support?

Discuss the development and future direction of Play.
Post Reply
scott brown
Posts: 26
Joined: Wed May 24, 2006 10:41 pm

sample rate support?

Post by scott brown » Fri Nov 10, 2006 2:35 pm

what sample rates does Play support for flac files?

User avatar
sbooth
Site Admin
Posts: 2445
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Re: sample rate support?

Post by sbooth » Fri Nov 10, 2006 5:39 pm

scott brown wrote:what sample rates does Play support for flac files?
I personally don't have any "real" non 16-bit/44.1 kHz files for testing, but Play should play any combination of bit depth and sample rate that is supported by FLAC. I'd appreciate hearing about any successes or failures you have with non-44.1 kHz files.

scott brown
Posts: 26
Joined: Wed May 24, 2006 10:41 pm

Post by scott brown » Fri Nov 10, 2006 5:45 pm

I tried a 24/88.2 flac file last night and it was just static

i can try 24 bit at 48, 96, 176.4 and 196 this weekend and let you know how those do. actually, i'll try 24/44.1, too.

User avatar
sbooth
Site Admin
Posts: 2445
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Post by sbooth » Fri Nov 10, 2006 8:34 pm

I grabbed McDougalsMen24bit_48kHz.flac and sister24bit_48kHz.flac from http://ff123.net/samples.html which are 24-bit/48 kHz samples and they played back correctly on my PowerBook.

The problem could be the 88.2 kHz sample rate; I'm not sure why it wouldn't work, but if you could send me a sample for testing it would help me figure things out.

User avatar
sbooth
Site Admin
Posts: 2445
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Post by sbooth » Tue Nov 14, 2006 4:54 am

This is strange- I tried both the 24/88.1 and 24/96 samples that you sent and both played just fine with my current build.

Could this be a hardware issue? Or one with the number of channels? I'm not sure what other factors could be at work here...

scott brown
Posts: 26
Joined: Wed May 24, 2006 10:41 pm

Post by scott brown » Tue Nov 14, 2006 12:30 pm

hmm...strange

i'm on a macbook pro, rev A, if that helps, on the Play build r180 and r199 (I tried the binaries you posted, and I just compiled r199 and had the same result). I can have my boss try on a g4 powerbook at work, or maybe even try on a dual g5...



but it's definitely all static on my machine...maybe i'll try some 24/44.1 and 24/48 files on my machine tonight after work to see if they work (if i'm home long enough, i'm heading into nyc tonight). 16 bit files are fine

scott brown
Posts: 26
Joined: Wed May 24, 2006 10:41 pm

Post by scott brown » Tue Nov 14, 2006 1:34 pm

i brought my machine to work, so I can test a bit now. I just tested a 24/48 file and it doesn't work either

Maybe this is a macbook pro thing? I'll see if i can try my boss's powerbook when he gets in...

User avatar
sbooth
Site Admin
Posts: 2445
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Post by sbooth » Wed Nov 15, 2006 5:04 am

In the hope that this is an endian issue, I took out the code that byte-swaps 24-bit FLAC samples. Since I'm using a PowerBook I won't be able to tell if this fixes the problem. Can anyone with an Intel machine try to play 24-bit FLAC audio with build 201 and let me know if it works?

scott brown
Posts: 26
Joined: Wed May 24, 2006 10:41 pm

Post by scott brown » Wed Nov 15, 2006 12:01 pm

works great. thank you!

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests