Problem with libcurl? on PPC

Discuss the development and future direction of Play.
Post Reply
tumble
Posts: 8
Joined: Tue Mar 25, 2008 8:02 am

Problem with libcurl? on PPC

Post by tumble » Wed Mar 26, 2008 6:41 am

Hi. I can't run Play versions 0.3 or r1077 on my Powerbook G3. Play 0.2 runs fine. When I try to run a recent version from the Finder, it starts to open, appears briefly in the Dock and then closes again (no windows or anything). When I run it from the Terminal (straight or in gdb), I get a message which suggests that there's a problem with the packaged libcurl Framework (maybe no PPC code?). The message is the same for both 0.3 and r1077.

Since Play 0.3 has been out for a while and nobody else has reported this, I wonder whether there's something wrong with my Mac ... but its setup is pretty normal (OS version 10.4.11), and it's not giving me any other problems.

Here's the message:

jason@adh10 ~/D/Play-r1077> ./Play.app/Contents/MacOS/Play
dyld: Library not loaded: @executable_path/../Frameworks/libcurl.framework/libcurl
Referenced from: /Users/jason/Desktop/Play-r1077/./Play.app/Contents/MacOS/Play
Reason: no suitable image found. Did find:
/Users/jason/Desktop/Play-r1077/./Play.app/Contents/MacOS/../Frameworks/libcurl.framework/libcurl: no matching architecture in universal wrapper
/Users/jason/Desktop/Play-r1077/Play.app/Contents/MacOS/../Frameworks/libcurl.framework/libcurl: no matching architecture in universal wrapper
fish: Job 1, “./Play.app/Contents/MacOS/Play ” terminated by signal SIGTRAP (Trace or breakpoint trap)

tumble
Posts: 8
Joined: Tue Mar 25, 2008 8:02 am

Re: Problem with libcurl? on PPC

Post by tumble » Wed Mar 26, 2008 6:43 am

P.S. I've just remembered that Play 0.3 USED to run on this very same G3. It stopped working after an operating system upgrade from Software Update. Don't remember exactly which one, but probably around 10.4.9 or 10.4.10.

User avatar
sbooth
Site Admin
Posts: 2445
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Re: Problem with libcurl? on PPC

Post by sbooth » Wed Mar 26, 2008 3:10 pm

It appears that the curl I distribute with Play isn't compiled for G3 processors:

Code: Select all

Fat header in: libcurl
fat_magic 0xcafebabe
nfat_arch 2
architecture ppc7400
    cputype CPU_TYPE_POWERPC
    cpusubtype CPU_SUBTYPE_POWERPC_7400
    offset 4096
    size 226068
    align 2^12 (4096)
architecture i386
    cputype CPU_TYPE_I386
    cpusubtype CPU_SUBTYPE_I386_ALL
    offset 233472
    size 218600
    align 2^12 (4096)
I will fix this for the next release, and in the next unstable. I guess there aren't too many G3 users left.

If the same version used to work on your computer, Apple must have replaced your system's libcurl in one of the software updates.

tumble
Posts: 8
Joined: Tue Mar 25, 2008 8:02 am

Re: Problem with libcurl? on PPC

Post by tumble » Thu Mar 27, 2008 12:56 am

That's what I hoped. Thanks very much for the planned fix.

There may not be many G3 users left, but once Play takes over the world, they'll all be using it, so it will be more than just me :D

Jason

tumble
Posts: 8
Joined: Tue Mar 25, 2008 8:02 am

Re: Problem with libcurl? on PPC

Post by tumble » Wed Jun 11, 2008 9:06 am

sbooth wrote:It appears that the curl I distribute with Play isn't compiled for G3 processors:
I will fix this for the next release, and in the next unstable. I guess there aren't too many G3 users left.
I'm missing my version 3, and it's been a long time between unstables. Any chance you could please make a G3-compatible libcurl framework and put it into the .tar.bz2 file of precompiled frameworks at http://files.sbooth.org? Then I could copy it into my copy of Play version 3.

Thanks very much.

Jason

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests