Adding Replaygain - does not stick!

Get help on playing your audio with Play.
Post Reply
shevans
Posts: 9
Joined: Fri Sep 11, 2009 3:40 pm

Adding Replaygain - does not stick!

Post by shevans » Wed Jan 13, 2010 7:19 pm

Ok, I'm going mad back in Septmber 09' it worked...

Ripping CD's using Max (cannot use Rip as the CD's have lots of C2 errors) and create FLAC files.

Open files in Play (one CD at a time) and add replaygain tags scanning by Album. Open same files in Tag and there is no replaygain tags or values, if I remove the tracks from Play and add them again, the values are also lost.

What have I done wrong?

User avatar
sbooth
Site Admin
Posts: 2445
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Re: Adding Replaygain - does not stick!

Post by sbooth » Thu Jan 14, 2010 1:42 am

That is strange- which version of Play are you running?

If you add RG with Play and then inspect the files with metaflac can you see the tags?

shevans
Posts: 9
Joined: Fri Sep 11, 2009 3:40 pm

Re: Adding Replaygain - does not stick!

Post by shevans » Thu Jan 14, 2010 6:31 am

metaflac was a pain, however the tags are not there, as if Play has not written the tags into the files.

I have tried both Play-0.3.tar.bz2 & Play-r1105.tar.bz2. 0.3 was working in September.... ah! I have upgraded to OS X 10.6.2 I wonder if thats the issue?

shevans
Posts: 9
Joined: Fri Sep 11, 2009 3:40 pm

Re: Adding Replaygain - does not stick!

Post by shevans » Fri Jan 15, 2010 2:27 pm

Tried on another machine, running Leopard, still no joy! The FLAC files do not contain the replay gain tags outside of Play.

Please could someone tell me step by stem on how to add the tags becuase its as if I need to save the Replay gain tags to the files once scanned.

shevans
Posts: 9
Joined: Fri Sep 11, 2009 3:40 pm

Re: Adding Replaygain - does not stick!

Post by shevans » Fri Jan 15, 2010 9:17 pm

What I found after a LOT of playing around is that....

CD's ripped with MAX to FLAC, will not take Replay gain values added by Play :!:

User avatar
sbooth
Site Admin
Posts: 2445
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Re: Adding Replaygain - does not stick!

Post by sbooth » Sat Jan 16, 2010 3:59 pm

Have you set a size to be reserved for metadata in Max's FLAC encoding settings? Perhaps the Max-encoded FLACs don't have adequate space in a free block to write the metadata, although I fail to see how this matters to Play.

shevans
Posts: 9
Joined: Fri Sep 11, 2009 3:40 pm

Re: Adding Replaygain - does not stick!

Post by shevans » Sun Jan 17, 2010 5:14 pm

8192 bytes are reserved, have not altered this setting as unsure what could happen....

Ripped some CD's using XLD and able to add replay gain using Play, so still unsure what my problem is.

shevans
Posts: 9
Joined: Fri Sep 11, 2009 3:40 pm

Re: Adding Replaygain - does not stick!

Post by shevans » Mon Jan 18, 2010 9:17 pm

Panic Over....

Well the culprit was Max, removing and reinstalling did not work but running the supplied script to remove the preferences did! even though I removed the file manually previously. :oops:

User avatar
sbooth
Site Admin
Posts: 2445
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Re: Adding Replaygain - does not stick!

Post by sbooth » Tue Jan 19, 2010 2:42 am

Glad everything is working now!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest