Play hangs after playing an ape file

Discuss Play, an open source multi-format audio player.
Post Reply
lonati
Posts: 1
Joined: Sat Dec 01, 2007 9:43 am

Play hangs after playing an ape file

Post by lonati » Sat Dec 01, 2007 9:49 am

I have just installed and used Play to play an ape file. The file will play fine but soon after finish playing the file, it will hang. I checked with Activity Monitor and found that Play is using almost all of available CPU power, thus the fan was running full speed. FYI, I'm using new Macbook running Leopard. Any idea what is happening?

Regards,
Sopian

Anantadev
Posts: 1
Joined: Sun Dec 02, 2007 1:21 pm

Re: Play hangs after playing an ape file

Post by Anantadev » Sun Dec 02, 2007 1:32 pm

Same story for me in Imac and in macPro.

tofisterra
Posts: 5
Joined: Mon Sep 17, 2007 12:23 am

Re: Play hangs after playing an ape file

Post by tofisterra » Sat Jan 05, 2008 1:20 am

I am having the same issue. It seems that play is attempting to continue playing even though the song is over. If you watch it even though the blue ball is all of the way to the right, the play time continues to tick forward. If I click on the play button to stop it then Play hangs and I have to force quit it. I am not sure if the console is giving me an error from force quitting it, or if this is internal to Play, but every time this happens I get two instances of the following error:

1/4/08 5:02:33 PM Play[801] Bad _contents: nan

I am using a macbook pro and the latest and greatest stable version of Play 0.3 (1071). Thanks a lot for such a great app.

tofisterra
Posts: 5
Joined: Mon Sep 17, 2007 12:23 am

Re: Play hangs after playing an ape file

Post by tofisterra » Sat Jan 05, 2008 1:22 am

An extra note is that it does only seem to happen with ape files. On top of this the ape files I am using don't seem to have any information built into the file since Play does not tell me anything but the filename. Play does seem to know on some level how long the music is supposed to go for, but just doesn't seem to stop when it should.

User avatar
sbooth
Site Admin
Posts: 2445
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Re: Play hangs after playing an ape file

Post by sbooth » Sat Jan 05, 2008 6:08 am

This is a bug- I've just committed a change to svn that fixes it. I will post a new unstable build tomorrow with the fix incorporated. Thanks for reporting this!

tofisterra
Posts: 5
Joined: Mon Sep 17, 2007 12:23 am

Re: Play hangs after playing an ape file

Post by tofisterra » Sun Jan 06, 2008 10:44 pm

I've just gone looking to download the latest unstable version, but could not find it. The latest svn build seems to be from Nov 18th or so on the Development page of the Forums. Where does one go now? Thanks.

User avatar
sbooth
Site Admin
Posts: 2445
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Re: Play hangs after playing an ape file

Post by sbooth » Mon Jan 07, 2008 4:46 am

I'm posting r1072 now, it has the fix.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest