FLAC, MPC issues / howto compile?

Discuss Play, an open source multi-format audio player.
Post Reply
jortgies
Posts: 1
Joined: Fri Aug 24, 2007 7:11 pm

FLAC, MPC issues / howto compile?

Post by jortgies » Fri Aug 24, 2007 7:27 pm

After experiencing major playback skipping during heavy Photoshop work, I asked myself if that might have been fixed in the svn repository. I just don't know how to handle that XCode project, as neither the command line nor the gui want to spit out a usable binary (after clicking "Build and Go" in XCode, I get the error "No launchable executable present at path.", compiling only takes a fraction of a second).

Also, mpc playback doesn't work for me, I can't even add mpc files to the library. As I understand from the front page if the website, Musepack is supposed to be supported, right?

Another thing I noticed is that equaliser settings are not stored.

Are these things known issues that will be fixed / did I do something wrong? :wink:

Greetings from Germany,
--j

User avatar
sbooth
Site Admin
Posts: 2445
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Re: FLAC, MPC issues / howto compile?

Post by sbooth » Tue Aug 28, 2007 1:44 am

Regarding the build issue, there are two targets in Play. One extracts the current svn version and embeds it into the code, and the other actually compiles. It sounds like you may have selected the svn version target.

For the skipping, this was also reported by another user who was able to adjust the buffer sizes to eliminate the problem. I am adding advanced preferences to permit this, but if you want to adjust them yourself in the meantime I could point you at the relevant thread here.

MPC files should play- I am able to play MPC files with no issues. How did you try to add the mpc files?

Finally, the equalizer settings should be stored. I will take a look.

Post Reply