Play coming along very nicely, despite pauses in the music

Discuss Play, an open source multi-format audio player.
Post Reply
ccapito
Posts: 3
Joined: Sat Jun 02, 2007 1:20 pm

Play coming along very nicely, despite pauses in the music

Post by ccapito » Sat Jun 02, 2007 1:36 pm

I must congratulate the developers! Play is coming along very nicely as a good, lightweight alternative to iTunes.
If development keeps up like this, it will surely become my standard player.

I just noticed one small thing while playing around with it. I have my music hosted on another computer in the network. The files sometimes pause for a short moment, possibly because of an empty buffer.

- Chris

User avatar
sbooth
Site Admin
Posts: 2445
Joined: Fri Dec 23, 2005 7:45 am
Location: USA
Contact:

Re: Play coming along very nicely, despite pauses in the mus

Post by sbooth » Sat Jun 02, 2007 3:28 pm

ccapito wrote:I just noticed one small thing while playing around with it. I have my music hosted on another computer in the network. The files sometimes pause for a short moment, possibly because of an empty buffer.
I've heard one similar report to this before, but it was for AFP on Linux. What format are the files and what kind of network setup do you have? Do the glitches happen for all file types, or only for certain kinds of files?

ccapito
Posts: 3
Joined: Sat Jun 02, 2007 1:20 pm

Re: Play coming along very nicely, despite pauses in the mus

Post by ccapito » Sun Jun 03, 2007 7:42 am

sbooth wrote: I've heard one similar report to this before, but it was for AFP on Linux. What format are the files and what kind of network setup do you have? Do the glitches happen for all file types, or only for certain kinds of files?
The files are hosted on an AFP share on another computer with OSX 10.4.9.
I should add that I am using the system preference SharePoints, which already gave me some trouble after the recent security update. Using iTunes, files would just stop somewhere in the middle and iTunes would start again with the next file. I found a switch somewhere and at least that problem isn't occurring anymore.

The problem occurs with AAC and MP3 files. It doesn't seem to have anything to do with the bitrate. I have kept various files open in Console.app to see if any errors are coming up on the system, but nothing shows up.

Because of the previous experiences with Sharepoints and iTunes, I will remove Sharepoints, restart the computer and test everything again.

ccapito
Posts: 3
Joined: Sat Jun 02, 2007 1:20 pm

Re: Play coming along very nicely, despite pauses in the mus

Post by ccapito » Sun Jun 03, 2007 8:46 am

ccapito wrote: Because of the previous experiences with Sharepoints and iTunes, I will remove Sharepoints, restart the computer and test everything again.
That seems to have done the trick. At least after listening to about 10 songs without pauses, I'm conviced that Sharepoints was the culprit.

Post Reply